0

我的帖子

个人中心

设置

  发新话题
Exchange Server 2010证书申请
安装好2010之后的一天,接到某小妞的电话说被入侵了。眉宇间瞬间石化了。。。心想这小妞不知道又干什么好事了!百米冲刺的走过去!一看,开始眉宇飞扬哈!见图

由于我们的用户都是内部用户,没打算到公网上去申请证书,所以,根据之前的规划,开始部署CA
本次分为以下3个部分
部署CA
绑定证书
用户端信任CA
一 部署CA
1.1 添加角色,选择“证书服务”

1.2 证书简介:安装CA后就无法更改计算机的名称和域设置

1.3 勾选如图

1.4 由于我们是域环境(exchange是必须要有域环境的),选择企业CA

1.5 由于是第一次部署,并且在根域上,我们选择根CA

1.6 设置私钥

1.7 为CA配置加密

1.8 配置CA名称

1.9 设置有效期

1.10配置证书数据库

1.11安装iis

1.12完成安装

1.13证书安装完成

二 绑定CA
2.1 打开EMC-服务器配置—Exchange证书,新建证书,输入一个有好的名字,这个根据自己的喜好,只是一个显示名

2.2 域范围:通配符证书,如果你申请了公网的尽量使用这个!配置简单!下一步
2.3 要OWA,Anywhere以及pop/Imap等选项的域名

2.4 这里还可以添加你想要的域名,比如你的ex的计算机名,这样就不用再访问owa的时候把域名全部输入了,因为我们后期还需要介绍RMS与Ex的结合,所以我这里直接添加好!

2.5 组织和位置,最后一步导出一个req文件

2.6 导出完成

2.7 打开CA申请的网页,申请证书

2.8 高级证书申请

2.9 使用base64编码申请

2.10 打开刚才导出的1.req文件,复制

2.11 粘贴到网页里,并选择web服务器证书模板,提交

2.12 web访问确认

2.13 下载证书,并保存

2.14 回到EMC,完成搁置请求

2.15 选择刚刚申请到的证书文件

2.16 完成导入

2.17 分配服务

2.18 添加服务器

2.19 勾选所选服务器上应有的服务

2.20 确认覆盖

2.21 完成后删除原有的自签名证书!
2.22 打开IE进行owa的登录

三 外出用户信任CA
说明:如果用户电脑在域里,那么他会自动的信任本域的CA,不需要我们动手去干预!但如果有一些电脑没有在域里,我们需要手动的去信任本域的CA
3.1 打开用户端的IE,进入CA的申请页面,提示证书有问题,说明我们还没有信任他!输入自己的域账号登陆

3.2 下载CA证书

3.3 允许证书操作

3.4 下载CA证书

3.5 双击打开下载的证书,点击安装

3.6 存储这个证书到我们的受信任的根证书颁发机构

3.7 确定导入,完成

3.8 打开IE,登陆OWA,已经不现实错误提示了


IT之梦---你---我---他
2013年01月07日



斑竹威武。。。。:)1 :)1 :)1 :)1



hen很好的 说 学习了!



2.11 提交以后没有反应,不知道是不是虚拟机的原因:'(



引用:
原帖由 bloodyhonor 于 2013-5-7 13:38 发表
2.11 提交以后没有反应,不知道是不是虚拟机的原因:'(
是用的IE吗?看下浏览器是否设置的严格的安全区域或者拦截了弹窗!



在线云服务--您身边的IT专家团--346105868
社区微软技术超级群-207150557
引用:
原帖由 IT之梦 于 2013-5-7 16:51 发表

是用的IE吗?看下浏览器是否设置的严格的安全区域或者拦截了弹窗!
非常感谢就是IE block了, 但为什么做完后用域里的电脑访问IE 进入owa的时候,还是没有证书的样子



引用:
原帖由 bloodyhonor 于 2013-5-8 13:20 发表

非常感谢就是IE block了, 但为什么做完后用域里的电脑访问IE 进入owa的时候,还是没有证书的样子
没有证书的样子是什么意思?能截图吗?



在线云服务--您身边的IT专家团--346105868
社区微软技术超级群-207150557
我每次做完完成搁置请求,证书就红叉,非得等一晚上才会好,然后再申请,证书就不红叉了。



引用:
原帖由 ycguaa 于 2013-5-10 10:53 发表
我每次做完完成搁置请求,证书就红叉,非得等一晚上才会好,然后再申请,证书就不红叉了。
红叉是说明本地计算机没有信任他,估计是你本地服务器还没有获取到CA服务器的信任,一般重启或者gpupdate一下就可以了!



在线云服务--您身边的IT专家团--346105868
社区微软技术超级群-207150557
好贴~ 收藏



LZ 大哥  我做完搁置请求后  新建的那个证书就没了。 只有默认的微软那个证书名字。  请问是什么情况啊?



引用:
原帖由 lzdilzdi 于 2015-5-12 09:46 发表
LZ 大哥  我做完搁置请求后  新建的那个证书就没了。 只有默认的微软那个证书名字。  请问是什么情况啊?
一般不会的,是不是无意删除了?重新做一个试试



在线云服务--您身边的IT专家团--346105868
社区微软技术超级群-207150557
有几个问题,
1.证书服务器要选域中的一台机器么
2.基本流程可以这么理解么? 先建好证书颁发服务器,然后从exchange服务器发起一个证书申请,拿着这个申请去证书颁发服务器获取证书,然后回来安装。装完后把exchange的服务器也授权给这个证书。服务器端设置完毕
3.当client端访问exchange服务器的时候,client端自动下载安装信任exchange服务器上的证书。

可以像我这样理解么?谢谢楼主



假如我域中又3台cas服务器,那么我每台服务器都要申请一下证书么?还是颁发给其中的一台机器就行了?或者另外两台要用同一个证书?

感谢!



引用:
原帖由 zhong.li 于 2015-7-19 23:25 发表
假如我域中又3台cas服务器,那么我每台服务器都要申请一下证书么?还是颁发给其中的一台机器就行了?或者另外两台要用同一个证书?

感谢!
申请一个证书。导出来,分别导入其他CAS服务器。



MCITP 2008 Server Administrator | Exchange 2013 MCP | Windows Server for Small and Medium Business MVP(2015-2016)
个人Blog:http://gshao.blog.51cto.com/
社区官方Exchange技术群:230282796
社区Exchange板块:http://bbs.51cto.com/thread-1143938-1.html
引用:
原帖由 gs_h 于 2015-7-20 09:55 发表

申请一个证书。导出来,分别导入其他CAS服务器。
非常感谢



按照文中步骤做的,2.16报错,是什么原因呢?
无标题.png (100.11 KB)

2015-12-14 16:40

无标题.png




引用:
原帖由 zlygxh10011 于 2015-12-14 16:40 发表
按照文中步骤做的,2.16报错,是什么原因呢?
可能服务器还没信任到根证书服务器,直接重新启动在尝试导入



在线云服务--您身边的IT专家团--346105868
社区微软技术超级群-207150557
引用:
原帖由 IT之梦 于 2015-12-16 18:11 发表

可能服务器还没信任到根证书服务器,直接重新启动在尝试导入
谢谢,后来没有改设置,然后今天又试了一下可以导入了..终于不会弹信任证书的问题了。谢谢 谢谢



2.2 到 2.3 这个界面是如何出现的,我的为何没有exchange域配置及证书域 ?



‹‹ 上一贴:在Exchange 2013中重置用户密码   |   下一贴:exchange2010服务器迁移 ››
  发新话题
快速回复主题
关于我们 | 诚聘英才 | 联系我们 | 网站大事 | 友情链接 |意见反馈 | 网站地图
Copyright©2005-2017 51CTO.COM
本论坛言论纯属发布者个人意见,不代表51CTO网站立场!如有疑义,请与管理员联系:bbs@51cto.com