0

我的帖子

个人中心

设置

  发新话题
从左至右区域分别为area 0,1,2  如图:192.168.3.1/24是R3换回口,划分在区域1中,R4的换回口划分在区域2中,我在R3中将区域4的换回口汇总,然后打算在R2中将所有的192.168网段全部汇总,请问为什么不可以汇总成一个呢?
   R1的路由表如下:

     34.0.0.0/24 is subnetted, 1 subnets
O IA    34.1.1.0 [110/3] via 12.1.1.2, 00:02:58, FastEthernet0/0
     23.0.0.0/24 is subnetted, 1 subnets
O IA    23.1.1.0 [110/2] via 12.1.1.2, 00:02:58, FastEthernet0/0
     8.0.0.0/24 is subnetted, 1 subnets
C       8.8.8.0 is directly connected, Loopback8
     12.0.0.0/24 is subnetted, 1 subnets
C       12.1.1.0 is directly connected, FastEthernet0/0
     192.168.3.0/32 is subnetted, 1 subnets
O IA    192.168.3.1 [110/3] via 12.1.1.2, 00:02:58, FastEthernet0/0
O IA 192.168.0.0/22 [110/3] via 12.1.1.2, 00:03:00, FastEthernet0/0

R2的配置:

!         
interface FastEthernet0/0
ip address 12.1.1.2 255.255.255.0
duplex auto
speed auto
!         
interface FastEthernet1/0
ip address 23.1.1.2 255.255.255.0
duplex auto
speed auto
!         
router ospf 100
router-id 2.2.2.2
log-adjacency-changes
area 1 range 192.168.0.0 255.255.252.0
area 1 virtual-link 3.3.3.3
network 12.1.1.0 0.0.0.255 area 0
network 23.1.1.0 0.0.0.255 area 1
!         

R3的配置:!         
interface Loopback1
ip address 192.168.3.1 255.255.255.0
ip ospf 100 area 1
!         
interface FastEthernet0/0
ip address 23.1.1.3 255.255.255.0
ip ospf cost 1
duplex auto
speed auto
!         
interface FastEthernet1/0
ip address 34.1.1.3 255.255.255.0
ip ospf cost 1
duplex auto
speed auto
!         
router ospf 100
router-id 3.3.3.3
log-adjacency-changes
no auto-cost
area 1 virtual-link 2.2.2.2
area 2 range 192.168.0.0 255.255.252.0
network 23.1.1.0 0.0.0.255 area 1
network 34.1.1.0 0.0.0.255 area 2
network 192.168.0.0 0.0.0.255 area 1
network 192.168.1.0 0.0.0.255 area 1
!         

为什么在R2上不能将所有的192.168网段全部汇总呢?请问这是什么原因呢?谢谢各位了



无标题.png (189.73 KB)

2013-1-20 22:07

无标题.png




有没有做virtual-link啊,看第一句话就觉得你这拓扑设计本身就有问题,所有非骨干area都要和骨干area 0相连,是不是这个原因。



前面还没看完,lz做了virtuallink的,汇总的方式不对 要分2个区域分别汇总,ospf 汇总命令 area  1  range  是对本区域1内的内部汇总
区域2的路由还要再汇总一次,我觉得是这个可能,没实践过。




本帖最后由 w822927 于 2013-2-21 09:55 编辑
引用:
原帖由 w822927 于 2013-2-21 09:15 发表
有没有做virtual-link啊,看第一句话就觉得你这拓扑设计本身就有问题,所有非骨干area都要和骨干area 0相连,是不是这个原因。



前面还没看完,lz做了virtuallink的,汇总的方式不对 要分2个区域分别汇总,ospf 汇总命令 area  ...
没用,都不能全部汇总



提示: 作者被禁止或删除 内容自动屏蔽
‹‹ 上一贴:DHCP应该配置在哪里?   |   下一贴:eigrp在声明网络的时候 加不加掩码有什么区别 ... ››
  发新话题
快速回复主题
关于我们 | 诚聘英才 | 联系我们 | 网站大事 | 友情链接 |意见反馈 | 网站地图
Copyright©2005-2017 51CTO.COM
本论坛言论纯属发布者个人意见,不代表51CTO网站立场!如有疑义,请与管理员联系:bbs@51cto.com