0

我的帖子

个人中心

设置

  发新话题
Esxi5.1部署完成后,发现esxi主机的时间过一段时间后就自动变了,每次都与真实的时间相差7个小时。不知道是怎么回事?esxi主机的biso我也清零过,还是无法解决。



你设置过时间了没?关闭自动时间更新



时间同步问题挺麻烦的。我们单位也碰到过时间问题。。
如果你指的是日志,那就没问题,日志里的时间与真实时间是差8个小时的。他用的是UTC时间,中国式东8区,应该+8小时。

如果是虚机时间的话,ESXi会与底层BIOS同步,同时还会与vcenter-server同步,在vcenter server中给ESXi设置NTP服务器,那个貌似没什么用(原厂人说的)。



引用:
原帖由 ss_hades 于 2013-6-13 09:19 发表
时间同步问题挺麻烦的。我们单位也碰到过时间问题。。
如果你指的是日志,那就没问题,日志里的时间与真实时间是差8个小时的。他用的是UTC时间,中国式东8区,应该+8小时。

如果是虚机时间的话,ESXi会与底层BIOS同步,同时还会 ...


我指的事虚拟机的时间,今天又变了。特别麻烦。一直要手动去更改。每次都相差七小时



引用:
原帖由 爱喝可乐的小白 于 2013-6-13 00:42 发表
你设置过时间了没?关闭自动时间更新
在哪里关闭时间更新?



如果你关闭了NTP,那就是关闭了
你发现ESXi时间不对的时候,这个时候的时区和你查多少?你查看过你的bios时间是多少吗?



引用:
原帖由 爱喝可乐的小白 于 2013-6-13 10:13 发表
如果你关闭了NTP,那就是关闭了
你发现ESXi时间不对的时候,这个时候的时区和你查多少?你查看过你的bios时间是多少吗?
bios的时间也一起变了。
ESXI主机中的时区可以修改吗?怎么改?



引用:
原帖由 爱喝可乐的小白 于 2013-6-13 10:13 发表
如果你关闭了NTP,那就是关闭了
你发现ESXi时间不对的时候,这个时候的时区和你查多少?你查看过你的bios时间是多少吗?
ESXI的时间一变,所有的虚拟机的时间都一起变。
麻烦啊



可以进入esxi的命令模式下。root/pwd,进去后date看看系统时间是啥。然后用date -s 00:00:00 来更改下。hwclock是查看硬件时间,然后hwclock -set -date="07/07/06 10:19" (月/日/年 时:分:秒),设置好了后,
硬件时钟与系统时钟同步:
# hwclock --hctosys(hc代表硬件时间,sys代表系统时间)
系统时钟和硬件时钟同步:(让系统的时间同步到硬件时钟)
# hwclock –systohc
你设置好了之后,再跑个2~3个小时,看看是否还出现异常。



好的,我试一下,谢谢!



引用:
原帖由 lizhenhui51 于 2013-6-13 14:16 发表
可以进入esxi的命令模式下。root/pwd,进去后date看看系统时间是啥。然后用date -s 00:00:00 来更改下。hwclock是查看硬件时间,然后hwclock -set -date="07/07/06 10:19" (月/日/年 时:分:秒),设置好了后,
硬件时钟与系统时 ...
esxi5.1怎么进入命令模式。我试了ALT+F1 后没法输入



引用:
原帖由 wuyiwj 于 2013-6-13 16:10 发表

esxi5.1怎么进入命令模式。我试了ALT+F1 后没法输入
你ESXI系统先telnet ip 22端口,ssh端口开了没,开的话,下个putty直接弄上esxi主机的IP,然后用户名和密码就能进了。



我机器的时间都不正确。能帮吗设置一下吗。详细的命令,谢谢!



引用:
原帖由 lizhenhui51 于 2013-6-13 14:16 发表
可以进入esxi的命令模式下。root/pwd,进去后date看看系统时间是啥。然后用date -s 00:00:00 来更改下。hwclock是查看硬件时间,然后hwclock -set -date="07/07/06 10:19" (月/日/年 时:分:秒),设置好了后,
硬件时钟与系统时 ...
我在esxi的命令模式下使用date -s 17:30:00 后提示:setting date not supported,use<esxcli system time set>
这是怎么回事?没法修改时间



有谁能告诉我怎么修改esxi的时间?在命令模式中的时间和在vSphere中的时间不一样。



lz有没有可能是主板的问题?



:P1 :P1 :P1 :P1 :P1



引用:
原帖由 爱喝可乐的小白 于 2013-6-14 00:36 发表
lz有没有可能是主板的问题?
是不是ESXI5.1下的DATE和HWCLOCK的命令格式有变?
我使用DATE命令后提示:setting date not supported;use<esxcli system time set>



引用:
原帖由 wuyiwj 于 2013-6-14 09:11 发表

是不是ESXI5.1下的DATE和HWCLOCK的命令格式有变?
我使用DATE命令后提示:setting date not supported;use
我试过了,确实不行,因为这个命令我之前也没有用过,在xen上面这个命令是可以的,你可以按照提示用cli试试~





我在这里设置好了,可是过一段时间就会自动跳了。



‹‹ 上一贴:vsphere+server08集群验证错误问题   |   下一贴:Hyper-v 2016 Linux安全启动 ››
  发新话题
快速回复主题
关于我们 | 诚聘英才 | 联系我们 | 网站大事 | 友情链接 |意见反馈 | 网站地图
Copyright©2005-2017 51CTO.COM
本论坛言论纯属发布者个人意见,不代表51CTO网站立场!如有疑义,请与管理员联系:bbs@51cto.com