0

我的帖子

个人中心

设置

  发新话题
-Dmaven.multiModuleProjectDirectory system propery is not set. Check $M2_HOME environment variable and mvn script match.

求各路大神帮忙看看可能是什么错误,在线等,急!!!



解决了吗?我也遇到了这个问题,以前没用过maven,我用的是myeclipse10,自带maven插件,在run的时候出现了和你一样的提示



引用:
原帖由 liuyungao512 于 2015-3-20 22:00 发表
解决了吗?我也遇到了这个问题,以前没用过maven,我用的是myeclipse10,自带maven插件,在run的时候出现了和你一样的提示
没有,百度谷歌了一圈没有任何发现,你解决了吗



引用:
原帖由 liuyungao512 于 2015-3-20 22:00 发表
解决了吗?我也遇到了这个问题,以前没用过maven,我用的是myeclipse10,自带maven插件,在run的时候出现了和你一样的提示
终于解决了,心好累。原来是maven版本与IDEA14.0.3不兼容,你也看看是不是和eclipse不兼容的问题



应该是目录结构不对吗?



引用:
原帖由 jujis008 于 2015-3-21 14:56 发表
应该是目录结构不对吗?
根目录结构没关系,你的maven版本可能和eclipse版本不兼容



我也有这个错误,不知道是怎么回事儿,把maven项目部署到tomcat上的时候出现的,环境变量用mvn -version都是对的,就是部署的时候不行,急求解答~



引用:
原帖由 奋斗的阿呆 于 2015-3-21 23:12 发表
我也有这个错误,不知道是怎么回事儿,把maven项目部署到tomcat上的时候出现的,环境变量用mvn -version都是对的,就是部署的时候不行,急求解答~
我的maven是3.3.1 jdk是1.8.40是不是不兼容呢,如果是怎么解决



引用:
原帖由 auralman 于 2015-3-21 12:20 发表

终于解决了,心好累。原来是maven版本与IDEA14.0.3不兼容,你也看看是不是和eclipse不兼容的问题
还真是兼容问题,我把maven换成3.1.1版本的就好了,看来好不能用最新的啊



引用:
原帖由 奋斗的阿呆 于 2015-3-21 23:12 发表
我也有这个错误,不知道是怎么回事儿,把maven项目部署到tomcat上的时候出现的,环境变量用mvn -version都是对的,就是部署的时候不行,急求解答~
八成是maven与你的IDE不兼容,建议换低版本的maven3.1



引用:
原帖由 奋斗的阿呆 于 2015-3-21 23:13 发表

我的maven是3.3.1 jdk是1.8.40是不是不兼容呢,如果是怎么解决
换成maven3.1



版本问题




本帖最后由 woshibigsail 于 2015-3-26 17:21 编辑
我的系统是ubuntu 14.10,开发环境是myeclipse2014,maven3.3.1,jdk1.8.0_40,也出现同样的问题为什么-Dmaven.multiModuleProjectDirectory system propery is not set. Check $M2_HOME environment variable and mvn script match.




本帖最后由 录福 于 2015-3-31 12:02 编辑
http://blog.csdn.net/sd4015700/article/details/44827327



,真是版本的问题,谢了!



试试(IDEA 14)File->setting->Build,Exe…->Build Tools->Maven->Runner->设置VM Options:-Dmaven.multiModuleProjectDirectory=$M2_HOME,这样的话不用改变版本。



我之前也遇到过  具体的解决方法记不得了 跟18楼的很像



‹‹ 上一贴:【活动结束】桃“礼”满天下,九月谢师恩 ...   |   下一贴:如何实现开机登录用户信息出现在D盘Users文件夹下 ... ››
  发新话题
快速回复主题
关于我们 | 诚聘英才 | 联系我们 | 网站大事 | 友情链接 |意见反馈 | 网站地图
Copyright©2005-2018 51CTO.COM
本论坛言论纯属发布者个人意见,不代表51CTO网站立场!如有疑义,请与管理员联系:bbs@51cto.com