0

我的帖子

个人中心

设置

  发新话题
路由器采用PPPOE拨号上网,路由器启用DHCP,PC自动获取IP等信息
未启用无线,不想折腾了


Current configuration : 1963 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
dot11 syslog
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.49        //排除地址
ip dhcp excluded-address 192.168.1.151 192.168.1.254  //排除地址
!
ip dhcp pool sdm-pool1  //建立拨号池
   import all
   network 192.168.1.0 255.255.255.0
   dns-server 61.153.177.196 61.153.177.197
   default-router 192.168.1.1
!
!
ip cef
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
vpdn enable
!
vpdn-group office
request-dialin
  protocol pppoe
l2tp tunnel receive-window 128
!
!
!
username admin privilege 15 secret 5 $1$5IqO$UlUUO8W1hSBD0iOxMmSc2/
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0  //LAN口
!
interface FastEthernet1
//LAN口
!
interface FastEthernet2
//LAN口
!
interface FastEthernet3
//LAN口
!
interface FastEthernet4
//WAN口
no ip address
duplex auto
speed auto
pppoe enable group global           //允许PPPOE拨号
pppoe-client dial-pool-number 1
!
interface Dot11Radio0   //WIFI,默认关闭
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1  //只能通过设置VLAN1,达到管理LAN口的地址,要是接F0接口不会自动获取IP的,就是没设置此地址
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer0   //建立虚拟拨号端口,网上教程都是Dialer1,通过SDM设置查到此路由器是Dialer0才正确
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin   //不知道宽带的拨号协议下,默认两种都设置
ppp chap hostname 宽带账号
ppp chap password 0 宽带密码
ppp pap sent-username 宽带账号 password 0 宽带密码
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0   //默认路由一定要做
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
end


1.jpg (167.29 KB)

2016-8-23 08:35

1.jpg

2.jpg (133.42 KB)

2016-8-23 08:35

2.jpg




本帖最后由 wb579aff4e6cdf6 于 2016-8-25 14:24 编辑
这个可以作为参考吧,某网友贴的http://bbs.51cto.com/thread-615559-1.html



引用:
原帖由 独自风雨中 于 2016-8-23 14:26 发表
这个可以作为参考吧,某网友贴的http://bbs.51cto.com/thread-615559-1.html
我现在有线还不能上网,PC能自动获得IP,可是不能上网。表现为不能连接到internet
还有,例子中的无线配置,对LAN口进行IP设置,
而851W不能在LAN设置地址,
我目前的配置是设置VLAN1地址,



没有报故障代码吗?



引用:
原帖由 itboos 于 2016-8-24 09:57 发表
没有报故障代码吗?
没有!!



‹‹ 上一贴:单位换PC设备,组装机,CPU是选龙芯好还是兆芯好? ...   |   下一贴:网神SecGate 3600防火墙配置问题 ››
  发新话题
快速回复主题
关于我们 | 诚聘英才 | 联系我们 | 网站大事 | 友情链接 |意见反馈 | 网站地图
Copyright©2005-2017 51CTO.COM
本论坛言论纯属发布者个人意见,不代表51CTO网站立场!如有疑义,请与管理员联系:bbs@51cto.com