0

我的帖子

个人中心

设置

  发新话题

我一开始只添加了s1,s2,s3三台设备
通过vlanif让vlan10 和vlan20互访了
下面的PC全部设置的静态IP

后面又想加一台路由当DHCP服务器,于是添加了AR1
通过AR1的g0/0/1口和S1的G0/0/1口相连
在AR1配置了两个ip pool分别为vlan10 (172.16.13.0/24)和vlan20(172.16.14.0/24)
配置AR1的G0/0/1口IP为172.16.0.2/24
配置S1的G0/0/1口 trunk并允许通过vlan10 vlan20
尴尬的发现DHCP下发不下去

就做了如图的单臂路由,就能下发DHCP了
觉得怪怪的,但我水平不行,说不上来

请各位大神指点一下,我做的这个实验有哪些错误?
在此先谢各位了

-------------------------------------------------------------------



经过版主指点,上面那个做法是太蠢了
按照版主的配置外自己改了一下,
在三层交换机上做vlan10 vlan20 vlan30,同时做DHCP
做了一个基本acl2000加nat连接外网
我测试是都通的,但是不知道对不对,规不规范
烦请各位大神看看,指正一下

拓扑.zip (7.03 KB)




本帖最后由 clviug9006 于 2017-10-8 23:31 编辑
引用:
原帖由 clviug9006 于 2017-10-8 17:25 发表
348276
我一开始只添加了s1,s2,s3三台设备
通过vlanif让vlan10 和vlan20互访了
下面的PC全部设置的静态IP

后面又想加一台路由当DHCP服务器,于是添加了AR1
通过AR1的g0/0/1口和S1的G0/0/1口相连
在AR1配置了两个ip p ...
你这做的不伦不类的东西。三层不三层,单臂不单臂的玩意。如果你单纯只是想用路由器做dhcp服务器。你没有必要做单臂路由。其实就算你要做dhcp也不用做单臂路由。毕竟你有三层交换。做个dhcp中继就够了。
我好久没有配置命令了,今天练练手,给你贴一个玩玩。



"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
引用:
原帖由 lygzhan 于 2017-10-8 20:44 发表

你这做的不伦不类的东西。三层不三层,单臂不单臂的玩意。如果你单纯只是想用路由器做dhcp服务器。你没有必要做单臂路由。其实就算你要做dhcp也不用做单臂路由。毕竟你有三层交换。做个dhcp中继就够了。
我好久没有配 ...
哈哈  确实是不伦不类 刚才改了  把单臂给去掉了 在三层上做dhcp了
期待超版的命令,学习学习




本帖最后由 clviug9006 于 2017-10-8 20:53 编辑
引用:
原帖由 clviug9006 于 2017-10-8 17:25 发表
348276
我一开始只添加了s1,s2,s3三台设备
通过vlanif让vlan10 和vlan20互访了
下面的PC全部设置的静态IP

后面又想加一台路由当DHCP服务器,于是添加了AR1
通过AR1的g0/0/1口和S1的G0/0/1口相连
在AR1配置了两个ip p ...
lsw1 配置



sysname Huawei
#
vlan batch 10 20
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
dhcp enable
#
diffserv domain default
#
drop-profile default
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password simple admin
local-user admin service-type http
#
interface Vlanif1
ip address 10.0.0.2 255.255.255.0
#
interface Vlanif10
ip address 192.168.13.1 255.255.255.0
dhcp select relay
dhcp relay server-ip 10.0.0.1
#
interface Vlanif20
ip address 192.168.14.1 255.255.255.0
dhcp select relay
dhcp relay server-ip 10.0.0.1
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
port hybrid pvid vlan 10
port hybrid untagged vlan 10
#
interface GigabitEthernet0/0/2
port hybrid pvid vlan 20
port hybrid untagged vlan 20
#
interface GigabitEthernet0/0/3
description TO_AR1
#
interface GigabitEthernet0/0/4
#
interface GigabitEthernet0/0/5
#
interface GigabitEthernet0/0/6
#
interface GigabitEthernet0/0/7
#
interface GigabitEthernet0/0/8
#
interface GigabitEthernet0/0/9
#
interface GigabitEthernet0/0/10
#
interface GigabitEthernet0/0/11
#
interface GigabitEthernet0/0/12
#
interface GigabitEthernet0/0/13
#
interface GigabitEthernet0/0/14
#
interface GigabitEthernet0/0/15
#
interface GigabitEthernet0/0/16
#
interface GigabitEthernet0/0/17
#
interface GigabitEthernet0/0/18
#
interface GigabitEthernet0/0/19
#
interface GigabitEthernet0/0/20
#
interface GigabitEthernet0/0/21
#
interface GigabitEthernet0/0/22
#
interface GigabitEthernet0/0/23
#
interface GigabitEthernet0/0/24
#
interface NULL0
#
interface LoopBack0
ip address 2.2.2.2 255.255.255.0
#
ospf 1 router-id 2.2.2.2
area 0.0.0.0
  network 192.168.13.1 0.0.0.0
  network 192.168.14.1 0.0.0.0
  network 10.0.0.2 0.0.0.0
#
user-interface con 0
user-interface vty 0 4
#
return
[Huawei]  




AR1配置

[V200R003C00]
#
snmp-agent local-engineid 800007DB03000000000000
snmp-agent
#
clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
drop illegal-mac alarm
#
set cpu-usage threshold 80 restore 75
#
dhcp enable
#
ip pool vlan10
gateway-list 192.168.13.1
network 192.168.13.0 mask 255.255.255.0
dns-list 8.8.8.8
#
ip pool vlan20
gateway-list 192.168.14.1
network 192.168.14.0 mask 255.255.255.0
dns-list 4.4.4.4
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
local-user admin service-type http
#
firewall zone Local
priority 15
#
interface GigabitEthernet0/0/0
ip address 10.0.0.1 255.255.255.0
dhcp select global
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
ip address 1.1.1.1 255.255.255.0
#
ospf 1 router-id 1.1.1.1
area 0.0.0.0
  network 10.0.0.1 0.0.0.0
#
user-interface con 0
authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return



"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
引用:
原帖由 lygzhan 于 2017-10-8 20:59 发表

lsw1 配置



sysname Huawei
#
vlan batch 10 20
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
dhcp enable
#
diffserv domain default
#
drop-profile default
#
aaa
authentication-sc ...
谢大神指点,我看的这本书没讲hybrid,好尴尬,又去百度的



拓扑.zip (7.03 KB)
引用:
原帖由 lygzhan 于 2017-10-8 20:59 发表

lsw1 配置



sysname Huawei
#
vlan batch 10 20
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
dhcp enable
#
diffserv domain default
#
drop-profile default
#
aaa
authentication-sc ...
版主,我又改了一个,您如果有时间,请再指点一下



引用:
原帖由 clviug9006 于 2017-10-8 17:25 发表
348276
我一开始只添加了s1,s2,s3三台设备
通过vlanif让vlan10 和vlan20互访了
下面的PC全部设置的静态IP

后面又想加一台路由当DHCP服务器,于是添加了AR1
通过AR1的g0/0/1口和S1的G0/0/1口相连
在AR1配置了两个ip p ...
能通应该是没有错误的。



"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
引用:
原帖由 clviug9006 于 2017-10-8 17:25 发表
348276
我一开始只添加了s1,s2,s3三台设备
通过vlanif让vlan10 和vlan20互访了
下面的PC全部设置的静态IP

后面又想加一台路由当DHCP服务器,于是添加了AR1
通过AR1的g0/0/1口和S1的G0/0/1口相连
在AR1配置了两个ip p ...
大体上没有什么错误。但细节上还有有缺陷。比如你的acl 写的不准确。还有回程路由写的也不准确。以你目前的拓扑和规划。你的回程路由应该是 192.168.1.0 255.255.254.0 172.16.8.1.不相信我给你画一个你就明白了。



"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
引用:
原帖由 clviug9006 于 2017-10-8 17:25 发表
348276
我一开始只添加了s1,s2,s3三台设备
通过vlanif让vlan10 和vlan20互访了
下面的PC全部设置的静态IP

后面又想加一台路由当DHCP服务器,于是添加了AR1
通过AR1的g0/0/1口和S1的G0/0/1口相连
在AR1配置了两个ip p ...




你看看你写的路由是不是有缺陷。



"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
引用:
原帖由 lygzhan 于 2017-10-9 08:45 发表



348291



你看看你写的路由是不是有缺陷。
是有缺陷,感谢版主指点,费心了



引用:
原帖由 clviug9006 于 2017-10-9 09:35 发表

是有缺陷,感谢版主指点,费心了
如果想写静态路由就要写精确匹配,你需要学习路由聚合。
如果不想写静态,直接跑路由协议就可以了。



"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
引用:
原帖由 lygzhan 于 2017-10-9 11:09 发表

如果想写静态路由就要写精确匹配,你需要学习路由聚合。
如果不想写静态,直接跑路由协议就可以了。
动态路由协议ospf和rip了解过,不过看到有的人说动态路由协议比较复杂,不容易配置好,所以只看了静态,打算放到最后再学动态路由协议
路由聚合打算马上开始学习
再次感谢版主



引用:
原帖由 clviug9006 于 2017-10-9 21:24 发表

动态路由协议ospf和rip了解过,不过看到有的人说动态路由协议比较复杂,不容易配置好,所以只看了静态,打算放到最后再学动态路由协议
路由聚合打算马上开始学习
再次感谢版主 ...
好吧。路由方向的学习主要是路由协议 如果 rip ospf isis ergip bgp mpls pim igmp 这些你不学,是不可能成为工程师的。交换方向的简单一些。也不算太简单。



"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
引用:
原帖由 clviug9006 于 2017-10-9 21:24 发表

动态路由协议ospf和rip了解过,不过看到有的人说动态路由协议比较复杂,不容易配置好,所以只看了静态,打算放到最后再学动态路由协议
路由聚合打算马上开始学习
再次感谢版主 ...
你说的不是很对,配置路由器协议太简单了。主要是原理很复杂。如果你只是想管理网络,学习HCNA就够了。基本就会配置了,但如果出问题很难排查,因为你不知道路由协议的工作原理。



"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
引用:
原帖由 lygzhan 于 2017-10-8 20:44 发表

你这做的不伦不类的东西。三层不三层,单臂不单臂的玩意。如果你单纯只是想用路由器做dhcp服务器。你没有必要做单臂路由。其实就算你要做dhcp也不用做单臂路由。毕竟你有三层交换。做个dhcp中继就够了。
我好久没有配 ...
主要是他没理解交换原理 这种模式下同时拥有路由器和三层交换机的情况下 选择路由器开启DHCP就是要玩单臂路由  如果选取三层交换机dhcp 不仅要使用vlanif 路由器本身还需要写静态路由 否则也是无法通讯



在三层路由交换的时候已经没有了vlan的概念



回复看一看



二层跑VLAN,三层跑路由



你可以在三层交换机作dhcp,为不同vlan分配不同的ip地址,有三层交换机就不用做单臂路由,一般在现实环境中很少人做单臂路由,除非没有三层交换机



引用:
原帖由 chao0028 于 2017-10-16 16:41 发表
你可以在三层交换机作dhcp,为不同vlan分配不同的ip地址,有三层交换机就不用做单臂路由,一般在现实环境中很少人做单臂路由,除非没有三层交换机
是的,当时这个做法太蠢了,我还没弄明白意思就来做实验了,现在也是一知半解
一直看到人说单臂路由是个重点,我以为实际应用中会很多.

再请教一下:好像hybrid配置起来更简单,不用考虑端口是和交换机连接还是和计算机连接,是否华为的交换机vlan 端口都配置hybrid好了?还有必要配置access和trunk吗?

初学+自学,问些白痴问题请谅解.



‹‹ 上一贴:自己画了一个拓扑,请大神教育!   |   下一贴:Quidway系列中低端路由器典型配置宝典 ››
  发新话题
快速回复主题
关于我们 | 诚聘英才 | 联系我们 | 网站大事 | 友情链接 |意见反馈 | 网站地图
Copyright©2005-2017 51CTO.COM
本论坛言论纯属发布者个人意见,不代表51CTO网站立场!如有疑义,请与管理员联系:bbs@51cto.com