0

我的帖子

个人中心

设置

  发新话题
[attach]349356[/attach]先上图
问题是交换机3上配置到19.0网段的浮动路由始终不能生效,研究了几天,没搞定,请高手看看。
模拟器文件已上传。
图片已上传。

QQ图片20171106173228.png (36.19 KB)

2017-11-6 17:38

QQ图片20171106173228.png

111.rar (17.84 KB)

2017-11-7 14:15, 下载次数: 31




本帖最后由 mo1681 于 2017-11-7 14:15 编辑
在交换机0上做的浮动路由可以生效,但在交换机3上就不能生效。
区别就是交换机0 上的下一跳是2个不同网段,
交换机3上的下一跳是同一网段的2个不同地址。




本帖最后由 mo1681 于 2017-11-7 14:14 编辑
@天月来了 @成追忆 @lover119   可以帮用户解决一下问题~



我是论坛逗比管理员
大家有事儿没事儿可以撩我~
引用:
原帖由 咖啡 于 2017-11-6 17:51 发表
@天月来了 @成追忆 @lover119   可以帮用户解决一下问题~
偶不会呢,看晕了那拓扑



家用小路由器的WAN口是固化NAT转换的,单向,只向上转,无法将WAN口来的访问转向LAN口下面。不支持WAN口前面的任何静态路由跳转。
建议拿胶布封闭小路由器WAN口,网线改插小路由器LAN口,关闭小路由器的DHCP服务,当交换机用。坚决使用WAN口的话,就只能那样了。

关于DMZ打印机,请看这里“点击进入”6楼看看。
引用:
原帖由 天月来了 于 2017-11-7 09:43 发表

偶不会呢,看晕了那拓扑
难住大神了,再来一个  @成追忆



我是论坛逗比管理员
大家有事儿没事儿可以撩我~
下载的那个页面不存在或已被删除



配置信息在下载包里,导入Cisco模拟器,即可ping测试!



你那个配置已经被删除了吧,换了两个浏览器都是这样的提示



引用:
原帖由 opty2010 于 2017-11-7 14:11 发表
你那个配置已经被删除了吧,换了两个浏览器都是这样的提示
我重新编辑上传了怎么还不行?晕



sw0:
Switch>en
Switch#show runn
Building configuration...

Current configuration : 1454 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
switchport access vlan 2
!
interface FastEthernet0/2
switchport access vlan 10
!
interface FastEthernet0/3
switchport access vlan 3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 192.168.109.2 255.255.255.0
!
interface Vlan3
ip address 192.168.19.254 255.255.255.0
!
interface Vlan10
ip address 192.168.116.97 255.255.255.0
!
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.109.1 5
ip route 192.168.1.0 255.255.255.0 192.168.116.98 6
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end





sw1:
Switch#show runn
Building configuration...

Current configuration : 1243 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
switchport access vlan 2
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.1.3 255.255.255.0
!
interface Vlan2
ip address 192.168.109.1 255.255.255.0
!
ip classless
ip route 192.168.19.0 255.255.255.0 192.168.109.2
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end



sw2:

Switch#show runn
Building configuration...

Current configuration : 1317 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
switchport access vlan 2
!
interface FastEthernet0/2
switchport access vlan 10
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 192.168.1.13 255.255.255.0
!
interface Vlan10
ip address 192.168.116.98 255.255.255.0
!
ip classless
ip route 192.168.19.0 255.255.255.0 192.168.116.97
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end







sw3:

Switch#show runn
Building configuration...

Current configuration : 1316 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.1.5 255.255.255.0
!
ip classless
ip route 192.168.109.0 255.255.255.0 192.168.1.3
ip route 192.168.116.0 255.255.255.0 192.168.1.13
ip route 192.168.19.0 255.255.255.0 192.168.109.2 10
ip route 192.168.19.0 255.255.255.0 192.168.116.97 20
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end




本帖最后由 mo1681 于 2017-11-7 14:25 编辑
switch3 只配了VLAN1的IP根本连不到 192.168.109.2  192.168.116.97
怎么能路由?
把VLAN2 VLAN10 IP配上去




本帖最后由 gogodidi 于 2017-11-7 16:41 编辑
引用:
原帖由 gogodidi 于 2017-11-7 16:40 发表
switch3 只配了VLAN1的IP根本连不到 192.168.109.2  192.168.116.97
怎么能路由?
把VLAN2 VLAN10 IP配上去
问题是按照现在的配置能从下面的pc ping通上面的电脑
但浮动路由不能生效,比如把交换机3上的f0/9
shudown   查看sw3的路由到19.0的路由还是走109这条路按浮动路由原理,此条目不可达,应该转到1.13上,
另外配置的路由从109.1改成1.3     116.97 改成1.13  同样不行

但在sw0上做测试浮动路由可以切换生效。



引用:
原帖由 mo1681 于 2017-11-7 17:08 发表

问题是按照现在的配置能从下面的pc ping通上面的电脑
但浮动路由不能生效,比如把交换机3上的f0/9
shudown   查看sw3的路由到19.0的路由还是走109这条路按浮动路由原理,此条目不可达,应该转到1.13上,
另外配置的路由从10 ...
sw0能浮动是因为你配了vlanIP产生了直连路由,断掉一个口后另一条直连路由优先起效,再去找你配的静态路由,所以能浮动。sw3没配VLANIP,没直连路由,能通是因为数据包pc->1.5-查表19段走109.2段->再查表走1.3->出站。断掉一个口后,因为没直连路由,你的静态路由还在,所以走向不受影响。
你这种配法有问题,路由器上下一跳应该指向自己能直连到的IP。你这不是莫名奇妙多绕了1跳。
至于直接配置静态1.3和1.13不浮动一样的道理。



引用:
原帖由 gogodidi 于 2017-11-7 17:35 发表

sw0能浮动是因为你配了vlanIP产生了直连路由,断掉一个口后另一条直连路由优先起效,再去找你配的静态路由,所以能浮动。sw3没配VLANIP,没直连路由,能通是因为数据包pc->1.5-查表19段走109.2段->再查表走1.3->出站。断掉一 ...
我在sw3上删除 ip route 192.168.19.0 255.255.255.0 192.168.109.2 10
         删除 ip route 192.168.19.0 255.255.255.0 192.168.116.97 20

   重新配置   ip route  192.168.19.0 255.255.255.0 192.168.1.3  10
              ip route  192.168.19.0 255.255.255.0 192.168.1.13  20

这样配置还是没有啊,我以前就是这样配的,没有才换成上面的配置。请解释



引用:
原帖由 mo1681 于 2017-11-8 10:42 发表

我在sw3上删除 ip route 192.168.19.0 255.255.255.0 192.168.109.2 10
         删除 ip route 192.168.19.0 255.255.255.0 192.168.116.97 20

   重新配置   ip route  192.168.19.0 255.255.255.0 192.168.1.3  ...
按理说 192.168.1.3 不可达时,应该自动切换到1.13 。



引用:
原帖由 mo1681 于 2017-11-8 10:45 发表

按理说 192.168.1.3 不可达时,应该自动切换到1.13 。
为什么不可达就会浮动?
你应该先搞清楚底层路由查询问题。
sw3你配的是静态路由,不管接口有没有断开,静态路由是不会消失的。
我上面应该说的很清楚了,之所以sw0能浮动因为在静态路由前有一层直连路由(这个路由来自你配置的vlan接口)优先判断,直连路由的状态是接口有没有UP或者down。



引用:
原帖由 gogodidi 于 2017-11-8 14:05 发表

为什么不可达就会浮动?
你应该先搞清楚底层路由查询问题。
sw3你配的是静态路由,不管接口有没有断开,静态路由是不会消失的。
我上面应该说的很清楚了,之所以sw0能浮动因为在静态路由前有一层直连路由(这个路由来自你配置 ...
你说的我还是没懂,以你说如何配置就能生效?



在楼主的实验拓扑中做个测试,以验证浮动路由的下一跳链路断开检测机制。

在拓扑中新增一台PC3,连接到SW0的F0/4接口,然后将SW0的F0/4接口加入到VLAN2,PC3的IP配置为192.168.109.XX/24,网关192.168.109.1。
此时在PC1上通过TRACERT命令跟踪192.168.1.5的路由走向,发现过SW0以后会走192.168.109.1;
然后继续测试浮动路由,在SW0上关闭F0/1接口。
继续在PC1上跟踪,发现192.168.1.5已经不通了,PING也不通。而按原架构,此时浮动路由应该生效,过SW0以后应该发往192.168.116.98,而此时明显浮动路由并没有生效。
然后继续测试,在SW0上关闭F0/4接口。
继续在PC1上跟踪,发现浮动路由生效,过SW0以后会走192.168.116.98,能PING通192.168.1.5.
打开SW0上的F0/1接口,浮动路由又会转回192.168.109.1,再打开F0/4接口,无影响。


原因:浮动路由机制下,下一跳链路的通断并不是以物理接口通断为依据,而主要是检测VLAN状态。如本架构中,SW0中下一跳IP为192.168.109.1,对应物理接口为F0/1,所属VLAN为VLAN2。
原架构中,F0/1断开后,因VLAN2只配置在F0/1单个物理接口,导致VLAN2断开,从而浮动路由认为当前下一跳链路状态异常,从而转为192.168.116.98;而在F0/4接口加入到VLAN2后,当F0/1接口断开时,F0/4仍正常,因此VLAN2状态正常,SW0并不认为当前下一跳链路不可达,导致浮动路由无法预期生效;而继续断开F0/4口,VLAN2所在物理接口全部断开,从而VLAN2状态转为断开,因此浮动路由开始生效,切换为192.168.116.98。

回到SW3配置,下一跳的两个接口以及连PC2的接口均属于VLAN1,此架构下完全无法触发浮动路由链路切换机制。
解决方法:使用不同的VLAN来和SW1,SW2对接,同时连PC的端口也必须使用不同的VLAN。



引用:
原帖由 zhaoyong209 于 2017-11-9 15:54 发表
在楼主的实验拓扑中做个测试,以验证浮动路由的下一跳链路断开检测机制。

在拓扑中新增一台PC3,连接到SW0的F0/4接口,然后将SW0的F0/4接口加入到VLAN2,PC3的IP配置为192.168.109.XX/24,网关192.168.109.1。
此时在PC1上通 ...
绝对心服口服,你是了解我的疑问的人,原来是vlan接口在搞怪,最好使用路由口,vlan接口使用那么旗下只能包含1个接口,我懂了!



引用:
原帖由 zhaoyong209 于 2017-11-9 15:54 发表
在楼主的实验拓扑中做个测试,以验证浮动路由的下一跳链路断开检测机制。

在拓扑中新增一台PC3,连接到SW0的F0/4接口,然后将SW0的F0/4接口加入到VLAN2,PC3的IP配置为192.168.109.XX/24,网关192.168.109.1。
此时在PC1上通 ...
兄弟,我在问你一个问题,路由配置下一条ip地址和配置出接口究竟有什么本质区别?什么情况下用下一条?什么情况下用出接口?还是无论什么情况下都可以?



‹‹ 上一贴:ssl client-win各版本,SSL VPN必备   |   下一贴:AdventNet_ManageEngine OpManager6.0 破解文件 ››
  发新话题
快速回复主题
关于我们 | 诚聘英才 | 联系我们 | 网站大事 | 友情链接 |意见反馈 | 网站地图
Copyright©2005-2017 51CTO.COM
本论坛言论纯属发布者个人意见,不代表51CTO网站立场!如有疑义,请与管理员联系:bbs@51cto.com