想进BAT?负载均衡必须懂!从入门到实操,linux老鸟带你走上高并发架构之路,详情点击>>>
0

我的帖子

个人中心

设置

  发新话题






路由器配置

交换机的F0/0已经配置成了trunk口




目前通过单臂路由已经实现了
Pc1能ping通 192.168.10.250   192.168.20.1  无法ping通192.168.20.2(PC2)
pc2能ping通 192.168.20.1 无法ping通192.168.30.1 更别提ping通 192.168.30.2(PC1)了 ---------------------------------------------------------------------------------------------------------------------
上面这个PC1 PC2不能互通的搞定了 查了一下所有电脑设备的配置,PC2是因为之前IP地址配成了192.168.20.1 跟网关冲突所以PING不出去。 但是后面我确实是改过成了20.2的 但是没改成功。 刚才我又重新改了一下20.2 出来 show了一下  显示IP地址还是20.1  没办法 只能再进PC2端口 NO IP ADD 再重新IP ADD 192.168.20.2 才配置成功 。 现在是PC1和PC2能互访了  2台PC都能ping 192.168.10.250   但是ping 其他段10段的还是PING不通  我确实是写了下一跳的 下午我再试试多配几条下一跳看看。




然后还想要2台PC可以访问外面的网络 怎么办? 路由器的e1/0口 IP地址是192.168.10.250(自动获取) 另一头是连的电脑物理网卡 IP是192.168.10.107我配置了下一条地址 ip route 0.0.0.0 0.0.0.0 192.168.10.107  (应该没错吧)然后我怎么给我的物理网卡配置回程路由呢?




本帖最后由 enjels 于 2018-6-11 11:45 编辑
ip route-static 192.168.30.0 255.255.255.0 192.168.10.250
192.168.20.0 255.255.255.0 192.168.10.250



vlan间互访
ip route-static 192.168.20.2 255.255.255.0 192.168.20.1
192.168.30.2 255.255.255.0 192.168.30.1



引用:
原帖由 mb5b191a522beea 于 2018-6-9 02:18 发表
vlan间互访
ip route-static 192.168.20.2 255.255.255.0 192.168.20.1
192.168.30.2 255.255.255.0 192.168.30.1
单臂路由 VLAN间还要配置静态路由的吗 ?



你路由器具备了trunk的打标撕标的能力吗 不具备的话路由器可是转发不了数据



有点没看明白,不是在路由起子e0/0起子接口,封装802.1q,指定允许vlan号,然后把下面交换机3个口全配成trunk,建vlan,端口加vlan,再把e1/0接口启用,配地址,默认就是全通的啊



看交换机的端口是否允许vlan通过,如果端口配置对就是因为没写回程路由


访问外网需要用nat转发
华为的方法是建一条ACL,
比如 acl 2000
规则写rule 5 permit source 192.168.0.0 0.0.255.255
然后在路由器执行 nat outbound 2000




本帖最后由 clviug9006 于 2018-6-10 00:37 编辑
51CTO论坛有移动端啦!扫码下载体验就送月会员哦!
单臂路由,两台PC的网关都落在路由器上面了,两台pc通信是没问题的。
假如外面的PC要跟内网PC互通,做内网PC所在网段的回程路由即可,下一跳指向192.168.10.250,建议路由器的外网接口配置为静态地址。。




引用:
原帖由 whhang 于 2018-6-10 00:49 发表
单臂路由,两台PC的网关都落在路由器上面了,两台pc通信是没问题的。
假如外面的PC要跟内网PC互通,做内网PC所在网段的回程路由即可,下一跳指向192.168.10.250,建议路由器的外网接口配置为静态地址。。

...
真是奇怪,看我上面的配置 应该是没问题的啊 现在是连内网都不能互访 好奇怪



引用:
原帖由 clviug9006 于 2018-6-10 00:35 发表
看交换机的端口是否允许vlan通过,如果端口配置对就是因为没写回程路由


访问外网需要用nat转发
华为的方法是建一条ACL,
比如 acl 2000
规则写rule 5 permit source 192.168.0.0 0.0.255.255
然后在路由器执行 nat o ...
交换机接路由器的那个端口我已经配置了trunk的



引用:
原帖由 qq5b194f440db8d 于 2018-6-9 16:03 发表
你路由器具备了trunk的打标撕标的能力吗 不具备的话路由器可是转发不了数据
具备的呀



交换机是不是开启了ip route了?



引用:
原帖由 lianyunfeng 于 2018-6-11 09:18 发表
交换机是不是开启了ip route了?
没有  开启IP ROUTING 就不是单臂路由了呀



路由器给vlan创建了子接口吗



引用:
原帖由 enjels 于 2018-6-11 09:24 发表

没有  开启IP ROUTING 就不是单臂路由了呀
路由

0.0.0.0 0.0.0.0 e1/0
192.168.20.0 255.255.255.0 192.168.20.1
192.168.30.0 255.255.255.0 192.168.30.1

应该是这么写,你试下



引用:
原帖由 enjels 于 2018-6-9 08:10 发表

单臂路由 VLAN间还要配置静态路由的吗 ?
需要。。。。。。。



引用:
原帖由 lianyunfeng 于 2018-6-11 09:40 发表

路由

0.0.0.0 0.0.0.0 e1/0
192.168.20.0 255.255.255.0 192.168.20.1
192.168.30.0 255.255.255.0 192.168.30.1

应该是这么写,你试下
下一跳填 20.1和30.1不能输入的  下一跳不能填自己的端口

我试了20.2 和30.2 都不行 奇怪了




本帖最后由 enjels 于 2018-6-11 11:41 编辑
引用:
原帖由 wx57b2b60735c09 于 2018-6-11 11:03 发表

需要。。。。。。。
尝试了 配了没用



引用:
原帖由 enjels 于 2018-6-11 11:26 发表

下一跳填 20.1和30.1不能输入的  下一跳不能填自己的端口

我试了20.2 和30.2 都不行 奇怪了
写vlan20  30  试试



引用:
原帖由 enjels 于 2018-6-8 15:52 发表
357649





路由器配置 357650

交换机的F0/0已经配置成了trunk口
357651



目前通过单臂路由已经实现了
Pc1能ping通 192.168.10.250   192.168.20.1  无法ping通192.168.20.2(PC2)
pc2能ping通 192.168.20.1 无法p ...
根据你的图 我敲了一边配置
Router#sh ip int b
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        unassigned      YES unset  up                    up

FastEthernet0/0.1      192.168.10.1    YES manual up                    up

FastEthernet0/0.2      192.168.20.1    YES manual up                    up
!
interface FastEthernet0/0.1
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!

SW
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 10
!
interface FastEthernet0/3
switchport access vlan 20



‹‹ 上一贴:求各位亲朋好友推荐一下性价比高的视频会议系统 ...   |   下一贴:电脑网卡掉包严重 ››
  发新话题
快速回复主题
关于我们 | 诚聘英才 | 联系我们 | 网站大事 | 友情链接 |意见反馈 | 网站地图
Copyright©2005-2018 51CTO.COM
本论坛言论纯属发布者个人意见,不代表51CTO网站立场!如有疑义,请与管理员联系:bbs@51cto.com