0

我的帖子

个人中心

设置

  发新话题
这是我在模拟器上做的dhcp的实验为什么获取不了正确的ip,求大神看看
微信截图_20181013172457.png (26.34 KB)

2018-10-13 17:34

微信截图_20181013172457.png

2.png (5.45 KB)

2018-10-13 17:34

2.png

3.png (18.68 KB)

2018-10-13 17:34

3.png




你创建了vlanif接口了吗,在vlanif接口下配置dhcp select global
我说的是华为的配置方法,华三应该差不多



51CTO论坛有移动端啦!扫码下载体验就送月会员哦!
这是什么模拟器,模拟的是华三设备吗?



你的dhcp地址池配置的网关为192.168.5.1,那么你的VLAN 5的IP地址就应该设置成192.168.5.1,我看你的vlan5没有做任何配置,你应该要interface vlan5 把vlan5的接口开启,然后再设置IP地址(192.168.5.1),最后PC再获取一下看看能不能获取到IP地址。



Huawei]vlan batch 4 5

Dhcp enable

[Huawei]int Vlanif 4   

[Huawei-Vlanif4]ip address 192.168.4.1 24  

[Huawei-Vlanif4]dhcp select interface

[Huawei-Vlanif4]dhcp server dns-list 192.168.4.1

[Huawei]int Vlanif 5   

[Huawei-Vlanif8]ip address 192.168.5.1 24

[Huawei-Vlanif8]dhcp select interface

[Huawei-Vlanif8]dhcp server dns-list 192.168.5.1

[Huawei]interface GigabitEthernet 0/0/4

[Huawei-GigabitEthernet0/0/4]port link-type access

[Huawei-GigabitEthernet0/0/4]port default vlan 4

[Huawei]interface GigabitEthernet 0/0/5

[Huawei-GigabitEthernet0/0/5]port link-type access

[Huawei-GigabitEthernet0/0/5]port default vlan 5




本帖最后由 南海十三少 于 2018-10-14 13:57 编辑
引用:
原帖由 sky2016a 于 2018-10-13 22:35 发表
你的dhcp地址池配置的网关为192.168.5.1,那么你的VLAN 5的IP地址就应该设置成192.168.5.1,我看你的vlan5没有做任何配置,你应该要interface vlan5 把vlan5的接口开启,然后再设置IP地址(192.168.5.1),最后PC再获取一下看看能 ...
我vlan5已经配置ip了



引用:
原帖由 盛下的果实 于 2018-10-13 20:55 发表
这是什么模拟器,模拟的是华三设备吗?
是的,是模拟华三的



引用:
原帖由 南海十三少 于 2018-10-13 22:56 发表
Huawei]vlan batch 4 5

Dhcp enable

[Huawei]int Vlanif 4   

[Huawei-Vlanif4]ip address 192.168.4.1 24  

[Huawei-Vlanif4]dhcp select interface

[Huawei-Vlanif4]dhcp server dns-list 192.168.4.1

[H ...
华三的写不了dhcp select interface,dhcp select global都写不了



引用:
原帖由 clviug9006 于 2018-10-13 20:41 发表
你创建了vlanif接口了吗,在vlanif接口下配置dhcp select global
我说的是华为的配置方法,华三应该差不多
华三的写不了dhcp select golbal



引用:
原帖由 whitest 于 2018-10-14 15:15 发表

华三的写不了dhcp select golbal
你把华三模拟器的project配置文件发出来 一起研究下



引用:
原帖由 sky2016a 于 2018-10-14 16:15 发表

你把华三模拟器的project配置文件发出来 一起研究下
version 7.1.075, Alpha 7571
#
sysname H3C
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
irf member 1 priority 1
#
dhcp enable
#
lldp global enable
#
system-working-mode standard
xbar load-single
password-recovery enable
lpu-type f-series
#
vlan 1
#
vlan 2
#
vlan 5
#
stp global enable
#
dhcp server ip-pool vlan5
gateway-list 192.168.5.1
network 192.168.5.0 mask 255.255.255.0
dns-list 202.96.128.86
#
interface NULL0
#
interface Vlan-interface1
ip address 192.168.1.2 255.255.255.0
#
interface Vlan-interface2
ip address 192.168.4.1 255.255.255.0
#
interface Vlan-interface5
ip address 192.168.5.1 255.255.255.0
#
interface FortyGigE1/0/53
port link-mode bridge
#
interface FortyGigE1/0/54
port link-mode bridge
#
interface GigabitEthernet1/0/1
port link-mode bridge
port access vlan 2
combo enable fiber
#
interface GigabitEthernet1/0/2
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/3
port link-mode bridge
port link-type trunk
port trunk permit vlan all
combo enable fiber
#
interface GigabitEthernet1/0/4
port link-mode bridge
port access vlan 5
combo enable fiber
#
interface GigabitEthernet1/0/5
port link-mode bridge
port access vlan 5
combo enable fiber
#
interface GigabitEthernet1/0/6
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/7
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/8
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/9
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/10
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/11
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/12
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/13
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/14
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/15
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/16
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/17
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/18
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/19
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/20
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/21
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/22
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/23
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/24
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/25
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/26
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/27
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/28
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/29
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/30
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/31
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/32
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/33
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/34
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/35
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/36
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/37
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/38
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/39
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/40
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/41
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/42
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/43
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/44
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/45
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/46
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/47
port link-mode bridge
combo enable fiber
#
interface GigabitEthernet1/0/48
port link-mode bridge
combo enable fiber
#
interface M-GigabitEthernet0/0/0
#
interface Ten-GigabitEthernet1/0/49
port link-mode bridge
combo enable fiber
#
interface Ten-GigabitEthernet1/0/50
port link-mode bridge
combo enable fiber
#
interface Ten-GigabitEthernet1/0/51
port link-mode bridge
combo enable fiber
#
interface Ten-GigabitEthernet1/0/52
port link-mode bridge
combo enable fiber
#
scheduler logfile size 16
#
line class aux
user-role network-operator
#
line class console
user-role network-admin
#
line class tty
user-role network-operator
#
line class vty
user-role network-operator
#
line aux 0
user-role network-operator
#
line con 0
user-role network-admin
#
line vty 0 63
user-role network-operator
#
ip route-static 192.168.2.0 24 192.168.1.1
ip route-static 192.168.3.0 24 192.168.1.1
#
radius scheme system
user-name-format without-domain
#
domain name system
#
domain default enable system
#
role name level-0
description Predefined level-0 role
#
role name level-1
description Predefined level-1 role
#
role name level-2
description Predefined level-2 role
#
role name level-3
description Predefined level-3 role
#
role name level-4
description Predefined level-4 role
#
role name level-5
description Predefined level-5 role
#
role name level-6
description Predefined level-6 role
#
role name level-7
description Predefined level-7 role
#
role name level-8
description Predefined level-8 role
#
role name level-9
description Predefined level-9 role
#
role name level-10
description Predefined level-10 role
#
role name level-11
description Predefined level-11 role
#
role name level-12
description Predefined level-12 role
#
role name level-13
description Predefined level-13 role
#
role name level-14
description Predefined level-14 role
#
user-group system



引用:
原帖由 whitest 于 2018-10-14 16:17 发表

version 7.1.075, Alpha 7571
#
sysname H3C
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
irf member 1 priority 1
#
dhcp enable
#
lldp global enable
#
system-wor ...
再把完整的拓扑图发一下



引用:
原帖由 sky2016a 于 2018-10-14 16:51 发表

再把完整的拓扑图发一下
G1/0/3下面是接了交换机吗?



引用:
原帖由 sky2016a 于 2018-10-14 16:51 发表

再把完整的拓扑图发一下
拓扑我是随便弄的
捕获.PNG (47.21 KB)

2018-10-14 16:54

捕获.PNG




引用:
原帖由 sky2016a 于 2018-10-14 16:52 发表

G1/0/3下面是接了交换机吗?
我下面的那个交换机是为了测试中继的时候准备的



求大神帮忙看看



没看到在vlan里面启用dhcp的配置

5楼的配置可以参考



‹‹ 上一贴:配置二层接入交换机的管理IP可以不用创建管理vlan吗?就 ...   |   下一贴:路由交换最难的三层MPLS 虚拟专用网终于会做了 ... ››
  发新话题
快速回复主题
关于我们 | 诚聘英才 | 联系我们 | 网站大事 | 友情链接 |意见反馈 | 网站地图
Copyright©2005-2018 51CTO.COM
本论坛言论纯属发布者个人意见,不代表51CTO网站立场!如有疑义,请与管理员联系:bbs@51cto.com