30+技术大牛,横跨5大技术领域 推出避坑干货专栏,让升职加薪不秃头 >>>
0

我的帖子

个人中心

设置

  发新话题

这是我的网络拓扑图,利用三层交换机划分的vlan,Switch2对应vlan2,Switch3对应vlan3,Switch4对应vlan4,无线路由器对应vlan5,然后用路由器实现vlan之间路由,但是我在二层交换机上未作配置,所以pc1和pc2能相互之间ping通,但是ping其他机器就通过不了,这是什么原因啊?要怎么配置使其可以互相访问?



引用:
原帖由 Alice1988 于 2018-12-30 23:43 发表
364604
这是我的网络拓扑图,利用三层交换机划分的vlan,Switch2对应vlan2,Switch3对应vlan3,Switch4对应vlan4,无线路由器对应vlan5,然后用路由器实现vlan之间路由,但是我在二层交换机上未作配置,所以pc1和pc2能相互之间ping通 ...
看你的意思是要单臂路由啊

给你演示一个吧。。。



"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
引用:
原帖由 Alice1988 于 2018-12-30 23:43 发表
364604
这是我的网络拓扑图,利用三层交换机划分的vlan,Switch2对应vlan2,Switch3对应vlan3,Switch4对应vlan4,无线路由器对应vlan5,然后用路由器实现vlan之间路由,但是我在二层交换机上未作配置,所以pc1和pc2能相互之间ping通 ...



"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
三层交换机要配置vlan10 vlan20  no shutdown




本帖最后由 lygzhan 于 2018-12-31 13:44 编辑
"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
理论上 三层交换机vlan间默认有理由的




在3560交换机上配置vlan2,vlan3,vlan4,vlan5,网关做在3560上,起三层功能,接入交换机与3560之间的互联端口做Trunk,客户端之间应该就能互通了.



可以做单臂路由




三层交换机开启ip routing 后就可以自动三层互访了。。



说单臂路由的就不要误导人家了,单臂基本已经淘汰(特殊环境除外),单臂是当初路由器的口紧缺不得以的,现在三层设备都有路由功能,三层设备应该不缺端口了吧。你的3560连得第一台2960为什么要2根线,是要做端口聚合吗,不是的话1根就够了,否则就会环路,你要个个VLAN互通,二层交换机也要简单配置。
3560核心配置:
Switch>enable
Switch#vlan database   创建VLAN
Switch(vlan)#vlan 2
Switch(vlan)#vlan 3
Switch(vlan)#vlan 4
Switch(vlan)#vlan 5
Switch(vlan)#exit
Switch#configure terminal   
Switch(config)#ip routing   开启三层交换机的路由功能
Switch(config)#interface vlan 2     配置对应VLAN的网关
Switch(config-if)#ip address 192.168.2.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface vlan 3
Switch(config-if)#ip address 192.168.3.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface vlan 4
Switch(config-if)#ip address 192.168.4.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface vlan 5
Switch(config-if)#ip address 192.168.5.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface range f0/1 - f0/10   把三层交换机上的下联口配置成trunk口
Switch(config-if-range)#switchport trunk encapsulation dot1q
Switch(config-if-range)#switc mode trunk
3560三层交换机配置完成,把2层2960插在3560的trunk口就可以,二层交换机上链口配置成trunk口,下联的加入相应的VLAN就可以
2960配置
Switch>enable
Switch#vlan database   创建VLAN
Switch(vlan)#vlan 2
Switch#configure terminal
Switch(config)#interface f0/24 把最后一个口作为上链口
Switch(config-if-range)#switc mode trunk
Switch(config)#interface rang f0/1 - f0/23  把1到23口加到VLAN 2
Switch(config-if-range)#switchport acc vlan 2
PC插在2960的1到23口,配个192.168.2.XX的地址就可以了。其他的二层交换机一样的配置,VLAN改下,就能全部互通了。

你3560上面的设备我不知道你要来干啥的,正式环境的话直接连出局设备就可以,如有服务器的话直接插3560上也可以,或弄个交换机划VLAN,给不同的服务器使用。



引用:
原帖由 zccqq 于 2019-1-2 16:37 发表
说单臂路由的就不要误导人家了,单臂基本已经淘汰(特殊环境除外),单臂是当初路由器的口紧缺不得以的,现在三层设备都有路由功能,三层设备应该不缺端口了吧。你的3560连得第一台2960为什么要2根线,是要做端口聚合吗,不是的话1根 ...
看楼主要求,一看就知道这是个作业。别人作业就是这么要求的。你非要给人家说单臂路由落后了。确实落后了,但考试还是要考的。



"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
如果有三层交换机  肯定不用单臂路由



这拓扑跟我现在呆的差不多一样,VLAN互访很简单的。你只要在三层开启ip routing就可以了。
1、所有VLAN在三层划分,然后在二层也划分相同VLAN
2、接三层口做TRUNK口,三层上面写个静态路由去路由器
3、再写个RIP2路由协议把网段写进去就可以了



三层交换机起  ip routing



51CTO论坛有移动端啦!扫码下载体验就送月会员哦!
也就版主负责任些,大家回复都是不看要求的 。。。一个劲的说用三层路由   - -!




本帖最后由 以前是新手 于 2019-1-8 23:44 编辑
引用:
原帖由 以前是新手 于 2019-1-8 23:42 发表
也就版主负责任些,大家回复都是不看要求的 。。。一个劲的说用三层路由   - -!
版主又不是神,
按这个拓扑和楼主的要求来看,确实不一定要单臂路由。因为已经有了三层交换机。
直接在三层交换机上启用ip routing ,然后划分vlan就可以了,当然单臂路由也可以
只是有了三层交换机很少有人会用单臂路由的。



"然后用路由器实现vlan之间路由" 审题不严谨啊..
必须单臂路由啊



路由



这个看要求是单臂路由,但是从实际生产环境来看,还是三层交换更普遍了,实用吧



引用:
原帖由 colusniky0529 于 2019-01-02 14:45 发表
三层交换机开启ip routing 后就可以自动三层互访了。。
正解




路由器的处理能力那比得上交换机,硬是要用路由的是 考试题吧,还是超旧的题!



‹‹ 上一贴:求推荐适合酒店用的路由器   |   下一贴:机房线路整理 ››
  发新话题
快速回复主题
关于我们 | 诚聘英才 | 联系我们 | 网站大事 | 友情链接 |意见反馈 | 网站地图
Copyright©2005-2019 51CTO.COM
本论坛言论纯属发布者个人意见,不代表51CTO网站立场!如有疑义,请与管理员联系:bbs@51cto.com