0

我的帖子

个人中心

设置

  发新话题
大神们好:

我zabbix客户端的agentd服务已经启动了,但是在server端图形界面上面提示没有连接,我用过zabbix_get测试过,时断时好 ,客户端里也没有错误日志,下面是我客户端启动服务的详细情况,server端里提示也在下面的图里,还有zabbix图像界面提示 Get value from agent failed: ZBX_TCP_READ() timed out  。


我现在排查的情况,网络正常,防火墙关闭,服务端ip没错。  那位大神帮忙解答一下,谢谢了!
zabbix问题.png (18.59 KB)

2017-9-30 10:45

客户端启动服务的情况

zabbix问题.png

服务端日志.png (8.31 KB)

2017-9-30 10:45

服务端日志提示

服务端日志.png




网上找了很多,都没能解决



引用:
原帖由 huningfei 于 2017-9-30 10:53 发表
网上找了很多,都没能解决
貌似走的公网地址么,长ping看看丢包率高不高



监控项获取时间较长,导致无法获取数据

1. 优化你的监控选项
2. 修改zabbix_server.conf&&zabbix_agentd.conf,修改TimeOut的值,默认是3秒



引用:
原帖由 Elfen_lied 于 2017-9-30 14:25 发表

貌似走的公网地址么,长ping看看丢包率高不高
长ping是不丢包的



引用:
原帖由 chengchow 于 2017-9-30 14:29 发表
监控项获取时间较长,导致无法获取数据

1. 优化你的监控选项
2. 修改zabbix_server.conf&&zabbix_agentd.conf,修改TimeOut的值,默认是3秒
timeout这个时间我已经设置了30秒了,只有一个客户端是这样的,别的都是正常的



zabbix_sender需要主动向服务器发送数据,而zabbix-server端的10051端口是不是被防火墙挡住了



引用:
原帖由 zjcnew 于 2017-10-10 13:45 发表
zabbix_sender需要主动向服务器发送数据,而zabbix-server端的10051端口是不是被防火墙挡住了
zabbix_server10051肯定没被挡住,因为别的机器都是通信正常的,我这边都是用的被动模式。



引用:
原帖由 huningfei 于 2017-10-10 11:09 发表

timeout这个时间我已经设置了30秒了,只有一个客户端是这样的,别的都是正常的
1. 手动获取时间是多少
2. 你设置的是服务器端的Timeout还是客户端的Timeout



引用:
原帖由 chengchow 于 2017-10-13 09:51 发表

1. 手动获取时间是多少
2. 你设置的是服务器端的Timeout还是客户端的Timeout
我刚开始是设置的服务端的,后来没效果,又把客户端的也设置了,最后还是不行。

手动获取的是说的用zabbix_get获取的那个时间吗?



引用:
原帖由 huningfei 于 2017-10-19 09:40 发表

我刚开始是设置的服务端的,后来没效果,又把客户端的也设置了,最后还是不行。

手动获取的是说的用zabbix_get获取的那个时间吗?
是的,可以用time zabbix_get从服务器端获取数据看时间



‹‹ 上一贴:linux如图求解   |   下一贴:Linux最帅版主所经历的面试题,全部答对月薪10K+ ... ››
  发新话题
快速回复主题
关于我们 | 诚聘英才 | 联系我们 | 网站大事 | 友情链接 |意见反馈 | 网站地图
Copyright©2005-2017 51CTO.COM
本论坛言论纯属发布者个人意见,不代表51CTO网站立场!如有疑义,请与管理员联系:bbs@51cto.com