0

我的帖子

个人中心

设置

  发新话题
华三路由器
interface
Ethernet0/1
(下联交换机接口)
descriptionto S1_48(下联交换机接口)

interface GigabitEthernet0/1.10

vlan-type dot1q vid 10 指定vlan10

ip address 192.168.1.1 255.255.255.128

interfaceGigabitEthernet0/1.20

vlan-type dot1q vid 20 指定vlan20

ip address 192.168.1.129 255.255.255.128


锐捷交换机
新建vlan

vlan 10

name oa_1

vlan 20

name oa_2

quit
删除int vlan 1老配置


interface VLAN 1

undo ip address

shutdown

quit
新加int vlan 20配置
设置交换机管理地址


interface VLAN 20

ip address 192.168.1.254

255.255.255.128

undo shutdown

quit

ip route-static 0.0.0.0 0.0.0.0 192.168.1.129
连接路由器或交换机级联接口配置

int GigabitEthernet 1/0/48(上联路由器接口或交换机级联)

description to 路由:G3

sw mode trunk


exit
开启交换机防环路设置

开启生成树命令

spanning-tree


通过上述划分vlan是想把oa_1、oa_2隔离开来,但是做完配置后oa_1下的电脑终端可以正常使用,oa_2下的电脑终端却不能正常上网,必须通过修改默认网关为192.168.1.129才可以正常使用。之前迈普路由器+锐捷交换机做同样的配置就没有出现上述的问题,想问下有大神知道这个是什么原因不?



你这个锐捷的是二层交换机吗,路由器上还做单臂路由。
如果是三层交换机不是这样配置的
1.路由器和交换机口配置成access口 ,交换机上随便设一个vlan和路由器Ethernet0/1连接,最好是不太用的vlan。和路由器设置成同一网段的ip。比如路由器192.168.255.1 交换机就用192.168.255.2.
2.交换机划分vlan,vlan地址作为pc的网关,思科的三层交换机还需ip routing这个命令开启路由功能,锐捷不太清楚要不要开启。
3.交换一条默认路由指向路由器 ip route 0.0.0.0 0.0.0.0 192.168.255.1
4.路由器上有到交换机网段上的回程路由
5.路由器上做了nat。



引用:
原帖由 opty2010 于 2019-5-20 10:23 发表
你这个锐捷的是二层交换机吗,路由器上还做单臂路由。
如果是三层交换机不是这样配置的
1.路由器和交换机口配置成access口 ,交换机上随便设一个vlan和路由器Ethernet0/1连接,最好是不太用的vlan。和路由器设置成同一网段 ...
这个就是简单的一个vlan隔离,锐捷是二层交换机,不知道是不是交换机品牌的问题,迈普的设备和锐捷的设备配合的话是没有问题的,oa_1、oa_2vlan下的电脑终端默认网关都是192.168.1.1就可以正常访问网络。
但是华三的设备和锐捷的设备配合就会出现oa_2必须得更换默认网关才能正常使用。



引用:
原帖由 wx5ce1fa8759605 于 2019-5-20 09:29 发表
华三路由器
interface
Ethernet0/1
(下联交换机接口)
descriptionto S1_48(下联交换机接口)

interface GigabitEthernet0/1.10

vlan-type dot1q vid 10 指定vlan10

ip address 192.168.1.1 255.255.255.128

int ...
你这是单臂路由器。。现在很少使用了。



"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
引用:
原帖由 lygzhan 于 2019-5-20 11:05 发表

你这是单臂路由器。。现在很少使用了。
那还有其他更好的解决方案么?能给介绍一下,学习学习



引用:
原帖由 wx5ce1fa8759605 于 2019-5-20 13:30 发表

那还有其他更好的解决方案么?能给介绍一下,学习学习
你的具体型号是什么?



"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
引用:
原帖由 lygzhan 于 2019-5-20 13:59 发表

你的具体型号是什么?
路由器 华三msr 30-11
交换机 锐捷S2952G-E



引用:
原帖由 wx5ce1fa8759605 于 2019-05-20 16:57 发表
路由器 华三msr 30-11交换机 锐捷S2952G-E
你2952g-e 是V3 的版本吗?V3指硬件版本
V3是弱三层设备
还有你配置是有问题的 你不需要起vlan 20 接口,但你启用了 那你VLAN20的默认网关肯定要和你配置的网关地址相同




引用:
原帖由 wx5ce1fa8759605 于 2019-5-20 16:57 发表

路由器 华三msr 30-11
交换机 锐捷S2952G-E
这两台都是三层设备,所以你的单臂路由就显得落后了。


本来想给你平滑过渡的,但好像不太行,你只能断网修改了。因为就2个端口。(没有加扩展版的情况下)

1。删除掉你现在路由器上的端口所有配置
2.进入端口0/1
配置为三层接口
配置ip为 10.10.10.1 255.255.255.0
3.配置路由
192.168.1.0 255.255.255.0 10.10.10.2


交换配置有2种,看你喜欢哪一种

1.进入48口
2.配置成3层接口
4.配置上ip 10.10.10.2 255.255.255.0

配置路由 0.0.0.0 0.0.0.0 10.10.10.1

第二种方法

建立vlan 4000
int vlan 4000
配置ip
10.10.10.2 255.255.255.0

把48口配置到vlan 4000 中  sw acc vlan 4000

配置路由  0.0.0.0 0.0.0.0 10.10.10.1

这样基本可以通信了。。

然后 配置 vlan 10 vlan 20
int vlan 20
ip add 192.168.1.129 255.255.255.128

int vlan 10
ip add 192.168.1.1 255.255.255.128

下面就看你的喜好了。如果你想用路由器做dhcp 那么就在 vlan 10 和 vlan 20里 做dhcp中继 (建议不要这么做。因为加重路由器的负担)
建议你在交换机上做dhcp 服务

service dhcp

ip dhcp pool VLAN41
network 192.168.41.0 255.255.255.0 (你要分配的网段) 你的应该是 network 192.168.1.0 255.255.255.128
dns-server 10.10.94.200 10.10.94.201 (dns服务器 按照你自己的实际情况填写)
default-router 192.168.41.1 (默认网关,按照你的实际情况填写 192.168.1.1)



vlan 20 的是默认网关是 192.168.1.129

这样基本就结束了。。

性能比你以前的要提升不少。。这是典型的三层交换网络
交换机充当了 核心设备

你那路由器已经很老了。能减少业务就减少一些吧。



"大师,什么是快乐的秘诀?"
"不要和愚者争论."
"大师,我完全不同意这就是秘诀."
"是的,你是对的。"
引用:
原帖由 lygzhan 于 2019-5-20 23:11 发表

这两台都是三层设备,所以你的单臂路由就显得落后了。


本来想给你平滑过渡的,但好像不太行,你只能断网修改了。因为就2个端口。(没有加扩展版的情况下)

1。删除掉你现在路由器上的端口所有配置
2.进入端口0/1
配置为三 ...
感谢您的耐心回复,这两天太忙没顾上看,我这边认真学习下您的回复








‹‹ 上一贴:求助Cisco路由器access-list访问控制列表问题 ...   |   下一贴:请问这个打印机应该怎么设置才能让4个房间的电脑都能 ... ››
  发新话题
快速回复主题
关于我们 | 诚聘英才 | 联系我们 | 网站大事 | 友情链接 |意见反馈 | 网站地图
Copyright©2005-2019 51CTO.COM
本论坛言论纯属发布者个人意见,不代表51CTO网站立场!如有疑义,请与管理员联系:bbs@51cto.com