0

我的帖子

个人中心

设置

  发新话题

这3种方法有啥区别



interface GigabitEthernet0/0/2


port link-type trunk


port trunk pvid vlan 147


port trunk allow-pass vlan 147



interface GigabitEthernet0/0/2


port link-type access


port default vlan 147



interface GigabitEthernet0/0/2


port hybrid pvid vlan 147


port hybrid untagged vlan 147





平常工作中遇到,实际上好像用起来也没啥区别。




扯谈,学艺不精

trunk是打标签的

access是不打标签的

怎么可能一样

PVID 本征VLAN,无标签



引用:
原帖由 erfdcv 于 2019-9-2 15:49 发表
扯谈,学艺不精

trunk是打标签的

access是不打标签的

怎么可能一样

PVID 本征VLAN,无标签

来再来学学,你们两个半桶水就别来误人子弟了。



看来我的问题问的不够准确,引起几个‘大神’的嘲讽。现在问题改成:3个配置都是没标签出去的,能直连PC或R接口(毋庸置疑),我就是搞不懂为啥要分3种方式?3种适合应用于哪些不同场景?还是我哪里理解错了。




本帖最后由 moshuran7 于 2019-9-3 13:39 编辑
引用:
原帖由 moshuran7 于 2019-9-3 13:17 发表

370681
来再来学学,你们两个半桶水就别来误人子弟了。
你理解什么是出站,入站没有?

如果accsse出站带标签,你pc还识别个p



引用:
原帖由 moshuran7 于 2019-9-3 13:28 发表
看来我的问题问的不够准确,引起几个‘大神’的嘲讽。现在问题改成:3个配置都是没标签出去的,能直连PC或R接口(毋庸置疑),我就是搞不懂为啥要分3种方式?3种适合应用于哪些不同场景?还是我哪里理解错了。 ...
access 是给终端用的,比如电脑,因为他们不识别带标签的帧。这种模式,这个端口只能属于这个VLAN。

trunk是 交换机跟交换机对接用的,VLAN中继带标签转发,本征VLAN不带标签。端口可以属于多个VLAN

hybrid 是混合口,主要是华为和H3C,还有一些厂商使用,思科是没有这种口的(认为没必要),hybrid口可以打标签,也可以剥离标签,所以使用场景很广泛,看环境。端口可以属于多个VLAN




本帖最后由 erfdcv 于 2019-9-3 18:08 编辑
引用:
原帖由 erfdcv 于 2019-09-03 18:05 发表
access 是给终端用的,比如电脑,因为他们不识别带标签的帧。这种模式,这个端口只能属于这个VLAN。trunk是 交换机跟交换机对接用的,VLAN中继带标签转发,本征VLAN不带标签。端口可以属于多个VLANhybrid 是混合口,主要是华为和H3C,还有一些厂商使用,思科是没有这种口的(认为没必要),hybrid口可以打标签,也可以剥离标签,所以使用场景很广泛,看环境。端口可以属于多个VLA ...
我认为他说的挺好   要想理解三种接口的区别必须理解标签 也就是在报文里嵌入标签来标记报文所属的vlan   三种接口的大部分功能是不同的(hybrid混合口有access  和trunk两者特性),都是也有相同的交叠部分。 刚好楼上就使用它们交叠部分的功能。也就是都允许vlan147的流量出,且脱掉标签,且默认进入接口的不带标签的流量流量默认认为是vlan147。即交换机会将这些默认流量当成vlan147对待。  实际上交换机对于进入的任何报文在内部处理时都会打上标签,只是在部分接口会脱掉标签之后再发出。




错了一个字  但是也有相同的交叠部分




每种接口都有自己独特的功能但是也有相同部分




引用:
原帖由 xiaozongpeng 于 2019-9-3 18:53 发表
每种接口都有自己独特的功能但是也有相同部分

好的谢谢,trunk也能发不带标签的,access存在的意义在哪呢,有哪些是trunk做不到的?



引用:
原帖由 moshuran7 于 2019-09-04 16:11 发表
好的谢谢,trunk也能发不带标签的,access存在的意义在哪呢,有哪些是trunk做不到的?
你的问题还真把我给问住了  ,第一次听到这样的问题  !你这个问题有点像 喝水有杯子 为什么还要发明碗呢?   我猜测有两种原因。1  历史的原因,研发的时候先研发access  。但是access功能有限,不能打标签 不能允许多个vlan,因此又发明了trunk.  至少我们在学习的过程中是先学习的access.然后再学习trunk.  2  trunk 不打标签是需要额外配置更多的命令。比如本征vlan 或者叫pvid. 而access一般是交换机接口的默认配置。即如果想实现不打标签过包 默认不用配置接口类型  配置简单些。




https://blog.51cto.com/xiaozongpeng/2170694
这里面有些视频  讲到了vlan 你可以看下!




引用:
原帖由 xiaozongpeng 于 2019-9-5 13:19 发表

你的问题还真把我给问住了  ,第一次听到这样的问题  !你这个问题有点像 喝水有杯子 为什么还要发明碗呢?   我猜测有两种原因。1  历史的原因,研发的时候先研发access  。但是access功能有限,不能打标签 不能允许多 ...



引用:
原帖由 erfdcv 于 2019-9-3 18:05 发表

access 是给终端用的,比如电脑,因为他们不识别带标签的帧。这种模式,这个端口只能属于这个VLAN。

trunk是 交换机跟交换机对接用的,VLAN中继带标签转发,本征VLAN不带标签。端口可以属于多个VLAN

hybrid 是混合口,主要是 ...
学习了。



引用:
原帖由 xiaozongpeng 于 2019-9-5 13:21 发表
https://blog.51cto.com/xiaozongpeng/2170694
这里面有些视频  讲到了vlan 你可以看下!

比喻恰当 优秀



引用:
原帖由 moshuran7 于 2019-09-02 10:18 发表
关于VLAN 以下端口配置有啥区别
kkk




引用:
原帖由 erfdcv 于 2019-09-02 15:49 发表
扯谈,学艺不精trunk是打标签的access是不打标签的怎么可能一样PVID 本征VLAN,无标签
hhh




kkk




引用:
原帖由 moshuran7 于 2019-9-4 16:11 发表

好的谢谢,trunk也能发不带标签的,access存在的意义在哪呢,有哪些是trunk做不到的?
trunk只有本征VLAN不带标签,也就是那个PVID,只支持一个VLAN而已不带而已



引用:
原帖由 erfdcv 于 2019-9-3 18:05 发表

access 是给终端用的,比如电脑,因为他们不识别带标签的帧。这种模式,这个端口只能属于这个VLAN。

trunk是 交换机跟交换机对接用的,VLAN中继带标签转发,本征VLAN不带标签。端口可以属于多个VLAN

hybrid 是混合口,主要是 ...
hybrid能举个实际中的例子吗。 我觉得有access和trunk口就都够了, hybrid有什么实际用途呢?请教



‹‹ 上一贴:cisco 2960 iso包丢失 上传bin包失败xmodem:: I/O err ...   |   下一贴:什么软件可以使用389端口 ››
  发新话题
快速回复主题
关于我们 | 诚聘英才 | 联系我们 | 网站大事 | 友情链接 |意见反馈 | 网站地图
Copyright©2005-2020 51CTO.COM
本论坛言论纯属发布者个人意见,不代表51CTO网站立场!如有疑义,请与管理员联系:bbs@51cto.com